Prologika Forums
Making sense of data

Forms Authentication secutiry extension.

rated by 0 users
Answered (Verified) This post has 0 verified answers | 5 Replies | 3 Followers

Top 150 Contributor
5 Posts
bshaik posted on Thu, Sep 29 2011 5:54 AM

Hi,

If any one can help me please.. i have sucessfully implemented the forms authentication for ssrs 2008 r2.. the next step which i was trying to look into giving permission to the users for the reports or doing the site setting permission ..

I am getting this error message...

 

library!ReportServer_0-3!1dc4!09/29/2011-10:01:56:: e
ERROR: Throwing Microsoft.ReportingServices.Diagnostics.Utilities.InternalCatalogException: ,
Microsoft.ReportingServices.Diagnostics.Utilities.InternalCatalogException:
 An internal error occurred on the report server. See the error log for more details.
 ---> System.Exception:
 Exception verifying user. A network-related or instance-specific error occurred while establishing a
 connection to SQL Server. The server was not found or was not accessible. Verify that the instance name
is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider,
error: 40 - Could not open a connection to SQL Server)

Please help.

All Replies

Top 150 Contributor
5 Posts
bshaik replied on Thu, Sep 29 2011 7:31 AM

Fixed this problem ... however there is another problem for me.. if anyone can help please ....

User '' does not have required permissions. Verify that sufficient permissions have been granted and Windows User Account Control (UAC) restrictions have been addressed.

Top 10 Contributor
2,299 Posts

Did you install SP1 for R2? There was an issue with the RTM version and Forms Authentication.

Top 150 Contributor
5 Posts
bshaik replied on Thu, Sep 29 2011 8:05 AM

Thanks ...however my pc is having sql server enterprise version R2 and i am upto date with all the updates and i am getting that error when i am doing the forms authentication .. sucessfully logged in and then i get that page.

Any help will be helpfull.

Thanks

shaik

 

 

Top 10 Contributor
2,299 Posts


Can't tell from the top of my head. Please debug the extension.

Top 50 Contributor
11 Posts

I received that error recently, when deploying to an additional server. Basically, you have to trick SSRS into using your admin login:

be RDP'ed into server desktop
close any IE windows that are open
navigate to your url, but use the /reportserver url instead of the uilogon, or /reports

use your administrator login from rsreportserver.config
now, without logging out, change the url to the /reports

this will let you into the report manager web interface
go to site settings in upper right
add yourself to administrator and user, using the custom username you have stored
then go to "home", and add yourself to the security of the Home folder

worked for me, let me know if this helps!

Page 1 of 1 (6 items) | RSS